Вмассиве 8 элементов напишите программу которая находит сумму положительнух чмсел и кол во чисел =0

Vladikf01Vlad220 Vladikf01Vlad220    2   12.09.2019 17:40    1

Ответы
Sapika Sapika  07.10.2020 10:07
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(8,-9,9); a.Println;
  Writeln('Сумма положительных ',a.Where(t->t>0).Sum);
  Writeln('Количество нулей ',a.Where(t->t=0).Count)
end.

Пример
2 6 -6 7 0 2 3 6
Сумма положительных 26
Количество нулей 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика