Вфайле в столбик записаны целые числа. напишите программу, которая определяет количество пар соседних чисел таких, что предыдущее число меньше последующего, и выводит результат в конец исходного файла.

Madi12kz Madi12kz    1   17.08.2019 17:10    1

Ответы
eegorov1996 eegorov1996  05.10.2020 01:09
//Dev-C++ 5.11 (C)

#include <stdio.h>

int main(void)
 {FILE* f;
 int counter=0,pre,next,b=1;
 f=fopen("input.txt","r");
 fscanf(f,"%d",&pre);
 if (feof(f))
  b=0;
 else
  fscanf(f,"%d",&next);
 while (!(feof(f)) && b)
  {if(pre<next)
   counter++;
  pre=next;
  fscanf(f,"%d",&next);}
 if(pre<next)
   counter++;
 fclose(f);
 f=fopen("input.txt","a");
 fprintf(f,"\n%d",counter);
 fclose(f);
 return 0;}

Пример содержимого input.txt до работы программы:
12
123124124
2132134
12412
123123312
12
12345
Пример содержимого input.txt после работы программы:
12
123124124
2132134
12412
123123312
12
12345
3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика