Вдвумерном массиве найтив двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (составить программу)

ОффниКим ОффниКим    1   31.05.2019 09:20    1

Ответы
nikiraspru nikiraspru  01.10.2020 15:36
Program Pr;
Var
a : array [1..100, 1..100] of integer;
i, max, min, j, n: integer;
Begin
cls;
read(n);
min := 100000;
max := -100000;
for i := 1 to n do 
   for j := 1 to n do     
       begin           
           read(a[i,j]);           
           if (a[i,j] > max) then             
               max := a[i,j];           
          if (a[i,j] < min) then             
               min := a[i,j];     
        end;     
 writeln ('Сумма = ', min + max);
writeln ('Разность = ', max - min);
writeln ('Произведение = ', max * min);

End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика