Ваша задача — написать программу, которая перемножает все цифры, введенного пользователем целого числа, пока оно не станет меньше либо равной 9. Число вводит пользователь с клавиатуры, и оно всегда должно быть больше нуля. Примеры:

999 -> 2 # 999 -> 9 * 9 * 9 = 729 -> 7 * 2 * 9 = 126 -> 1 * 2 * 6 = 12 -> 1 * 2 = 2

1000 -> 0

423 -> 8

1 -> 1
Надо решить без использования функций

MartynaEvgeneva MartynaEvgeneva    3   08.08.2022 22:52    4

Ответы
BOT1111111 BOT1111111  08.08.2022 22:53

print("Введите целое число")

n = int(input());

i = 0

multiple = 1

string = str(n)

do = len(string)

while i < do:

   multiple = multiple * (n % 10)

   n = int(((n - n % 10) / 10))

   i += 1

   if (i == do):

       if (multiple > 9):

           n = multiple

           multiple = 1

           i = 0

           string = str(n)

           do = len(string)

       else:

           break

print("результат: ",multiple)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика