Вас написать программу.написать программу- 1)с генератора случайных чисел создать н числа в диапазоне с [-50; 50](длину массива н надо ввести с клавиатуры) 2)надо вывести сделанный массив на экран 3)нужно вычислить и вывести,какое количество парных чисел 4)и вывести на экран все парные числа. вас нужно до завтра сделать.если можете мне, .

dolback dolback    3   31.05.2019 04:20    6

Ответы
ankreinas ankreinas  01.07.2020 14:38
Program gt;
var a:array[1..100000]of integer;
i,h,j,k,p:integer;
begin
randomize;
readln(h);
for i:=1 to h do
begin
a[i]:=random(101)-50;
write(a[i],' ');
end;
writeln;
for i:=1 to h-1 do
for j:=1 to h-1 do
begin
k:=a[j+1];
if(a[j]>a[j+1])then begin
a[j+1]:=a[j];
a[j]:=k;
end;
end;
p:=0;k:=1;
for i:=2 to h do
begin
if(a[i]=a[i-1])then k:=k+1;
if(a[i]<>a[i-1])or(i=h)then  begin
if(k>=2)then begin
p:=p+1;
writeln(a[i-1],' ',a[i-1]);
end;
k:=1;
end;
end;
writeln(p,' кол-во парных чисел без повторений');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика