Вариант 2.нетисел в1. напишите программу, которая в последовательности натуральных чисел определмаксимальное число, оканчивающееся на 7. программа получает на вход количесіпоследовательности, а затем сами числа. в последовательности всегда имеется число,оканчивающееся на 7.количество чисел не превышает 1000. введённые числа по модулю не превышают 50 .2. напишите программу, которая в последовательности натуральных чисел определяет суммучисел, оканчивающихся на 3. программа получает на вход количество чисел впоследовательности, а затем сами числа.3. напишите программу, которая в последовательности натуральных чисел определяет количестчисел, кратных 3 и оканчивающихся на 4. программа получает на вход количество чисел впоследовательности, а затем сами числа.​

кристинка0051 кристинка0051    2   13.05.2019 11:06    1

Ответы
Lena163121 Lena163121  10.06.2020 00:21
Задание 1var    i, N, inputNumber, max: integer;begin    Write('Введите количество чисел: ');    Readln(N);        for i := 1 to N do        begin            Write('Введите число: ');            Readln(inputNumber);                        if (inputNumber mod 10 = 7) then                if (inputNumber > max) then                    max := inputNumber;        end;        if (max = 0) then        Write('В последовательности нет чисел, оканчивающихся на 7')    else Write('Максимальное число, оканчивающееся на 7: ', max);end.Задание 2var    i, N, inputNumber, sum: integer;begin    Write('Введите количество чисел: ');    Readln(N);        for i := 1 to N do        begin            Write('Введите число: ');            Readln(inputNumber);                        if (inputNumber mod 10 = 3) then                sum := sum + inputNumber;        end;        if (sum = 0) then        Write('В последовательности нет чисел, оканчивающихся на 3')    else Write('Сумма чисел, оканчивающихся на 3: ', sum);end.Задание 3var    i, N, inputNumber, valueOfNumbers: integer;begin    Write('Введите количество чисел: ');    Readln(N);        for i := 1 to N do        begin            Write('Введите число: ');            Readln(inputNumber);                        if ((inputNumber mod 10 = 4) and (inputNumber mod 3 = 0)) then                valueOfNumbers := valueOfNumbers + 1;        end;        if (valueOfNumbers = 0) then        Write('В последовательности нет чисел, оканчивающихся на 4 и кратных 3-м')    else Write('Сумма чисел, оканчивающихся на 4 и кратных 3-м: ', valueOfNumbers);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика