tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вариант 1. 1. дан линейный
Вариант 1. 1. дан линейный массив a[1..n], содержащий целые числа. посчитать сумму положительных чисел и распечатать номера таких чисел.
Kizi89
3 02.10.2019 23:50
5
Ответы
myrrr14
21.08.2020 20:51
Const N=20;
var a:array[1...N] of integer;
s,i:integer;
begin
for i:=1 to N do begin
write ('A='); read (a[i]);
end;
s:=0;
for i:=1 to N do begin
if a>0 then begin
s:=s+a;
write (i);
end;
end;
write (s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Emulov
13.12.2021 08:04
Нужно написать программу в Паскале...
elvin123451
16.09.2021 10:08
Інформацію , що відбиває правдиве положення справ , називають : а) зрозумілою , б) достовірною , в) об єктивною, г)повною, д) корисною...
Mynir
16.09.2021 10:04
Перевести у двійковий код числа: 125,99,33...
s1mple72
11.08.2019 09:50
Исполнитель чертёжник перемещается на координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться на (a, b) (где a, b — целые числа),...
simonlol98
11.08.2019 09:50
Впиши в клеточки слова-ответы номер 102 информатика...
KARAZINO
27.09.2019 01:01
Сэкзаменом pascal: 1 : треугольник задан координатами своих вершин на плоскости. составить программу, которая определит, является ли он равносторонним, равнобедренным...
08760000
27.09.2019 00:20
Вычислить количество символов и информациионный объём печатного текста на 23 страниц если на 1 страницу 48 строк по 30 символов....
влад2318
27.09.2019 00:16
Егэ_информатика_№14 объясните подробно, как это делается. (ответ 1122) исполнитель редактор получает на вход строку цифр и преобразовывает её. редактор может выполнять...
Elirgon88
27.09.2019 01:10
Добрый день, мне надо выводить 5-ти битное число в порт, в 8 бит я могу вывести то 0, до 255, я малость туплю, но какой диапазон будет для 5-ти бит? типа от нуля до...
Nadezda1997
27.09.2019 01:10
Какие существуют основные философские концепции информации?...
Популярные вопросы
Река течёт,катит(катить,1 спр) рожь на печи...
1
Частицы не и ни пишутся слитно лили нет...
1
Кораблики крапивин краткое содержание...
2
Замени в этом ребусе буквы такими цыфрами ,чтобы получились верные...
2
Указать исконные или заимствованные словарные слова: платок, деревня,...
3
20 напишите уравнение касательной к графику функции проведенной через...
2
Выполни разностное сравнения данных площадей вычисление проведи столбиком....
3
Применение отражения света в технике...
2
Иванов договорился со своим другом петровым, что тот даст ему в аренду...
2
Ёлочки листьями украсились,грибы под листьями спрятались.синтаксический...
2
var a:array[1...N] of integer;
s,i:integer;
begin
for i:=1 to N do begin
write ('A='); read (a[i]);
end;
s:=0;
for i:=1 to N do begin
if a>0 then begin
s:=s+a;
write (i);
end;
end;
write (s);
end.