Вам дана программа, в которой создается массив и выводится на экран а также вводятся 2 числа: n и k - количество элементов и значение первого элемента массива. Дополните программу таким образом, чтобы массив заполнялся по следующему правилу: каждый следующий элемент на три больше предыдущего.

#include
using namespace std;
int main() {
int a[100], n, k;
cin >> n >> k;
// место для вашего фрагмента программы
for (int i = 0; i < n; i++) {
cout << a[i] << " ";
}
return 0;
}

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) - количество элементов.

На следующей строке вводится целое число - первый элемент массива. Все числа по модулю не превосходят 10000.

Формат выходных данных
В качестве ответа выведите массив

Примечания
В задачу требуется отправлять только указанный фрагмент кода.

P.s язык программирования С++

malaxov04 malaxov04    1   27.03.2020 17:54    4

Ответы
aiha4567 aiha4567  12.10.2020 07:18

Объяснение:

a[0]=k;

for (int i = 1; i < n; i++) {

a[i]=a[i-1]+3;

}

ПОКАЗАТЬ ОТВЕТЫ
maga050508 maga050508  12.10.2020 07:18

   a[0] = k;

   for (int i = 1; i < n; i++)

       a[i] = a[i-1] + 3;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика