Вам дан массив из n целых чисел. вы должны найти в этом массиве минимум и максимум, после чего подсчитать их усреднённое значение. формат входных данных в первой строке входных данных находится одно натуральное число n (n≤105) — количество элементов в массиве. во второй строке находятся n целых чисел, не превышающих по модулю 109 — элементы массива. формат выходных данных требуется вывести усредненное значение минимума и максимума. примеры входные данные 5 7 2 1 8 5 выходные данные 4.5

lllaasaw lllaasaw    2   20.03.2019 18:49    9

Ответы
Masha1211111111 Masha1211111111  26.05.2020 09:45

И что тут сложного?

#include <iostream>

using namespace std;

int main()

{

   int n;

   

   cin >> n;

   

   int32_t arr[n];

   

   for (size_t i = 0; i < n; ++i)

   {

       cin >> arr[i];

   }

   

   int32_t max = arr[0], min = arr[0];

 

   for (auto &i : arr)

   {

       if (i > max) max = i;

       if (i < min) min = i;

   }

   

   cout << static_cast<float>(max + min) / 2 << "\n";

   

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика