В программе описан одномерный целочисленный массив с индексами от 1 до 10. Ниже представлен фрагмент программы, обрабатывающей данный массив:
n := 10;
for i := 1 to n do begin
A[n+1-i] := 2*A[i];
end;
В начале выполнения этого фрагмента в массиве находились числа:1,2,3,4,5,6,7,8,9,10, т.е. А1=1 А2=2 и т.д. укажите значение которое после выполнения указанного фрагиента программы имеют два или более элемента массива.если таких чисел несколько укажите наибольшее.

Малышкалюбитспать Малышкалюбитспать    1   16.04.2021 01:31    2

Ответы
кек786564434 кек786564434  16.05.2021 02:21

был

1 2 3 4 5 6 7 8 9 10

стал

4 8 12 16 20 10 8 6 4 2

Объяснение:

var

a : array[1..10] of integer = (1,2,3,4,5,6,7,8,9,10);

i, n: integer;

k: integer;

Begin

 n := 10;

 for i := 1 to n do begin

   A[n+1-i] := 2*A[i];

 end;

 for i := 1 to n do

   write(a[i], '  ');

End.


В программе описан одномерный целочисленный массив с индексами от 1 до 10. Ниже представлен фрагмент
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика