В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр.
Пример:
Введите число:
1234
Cумма цифр 10
Составьте программу для питона

levgoncharenko levgoncharenko    3   14.11.2020 12:00    11

Ответы
almaz20004 almaz20004  14.12.2020 12:02

number = int(input("Введите число: "))

amount = 0

while number > 0:

   amount += number % 10

   number //= 10

print("Сумма цифр =", amount)

Объяснение:

number = int(input("Введите число: ")) # Ввод целочисленного значения с клавиатуры

amount = 0 # Переменная, хранящая сумму, равна 0

while number > 0: # Пока значение переменной number > 0

   amount += number % 10 # // Суммируем последнюю цифру от числа

   number //= 10 # // Отделяем эту цифру

print("Сумма цифр =", amount) # // Выводим ответ

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика