В питоне написать программу: 1. Дано предложение. Создать множество, содержащее буквы, которых нет в этом
предложении.
2. Заданы имена девочек. Определить, какие из этих имен встречаются во всех
классах данной параллели, которые есть только в некоторых классах и какие из
этих имен не встречаются ни в одном классе.

котик957 котик957    3   18.03.2021 18:34    4

Ответы
даша3635 даша3635  17.04.2021 18:36

1:

s = 'Это некоторое предложение'

a = ord('а')

chars = [rrchr(i) for i in range(a,a+34) if not rrchr(i) in s and i != a+32]

print(chars)

2:

parallel = [('имя1','имя2','имя3','имя4'),('имя1','имя2','имя5'),('имя2','имя4')]

names = ['имя1','имя2','имя3','имя4','имя5','имя6']

presence = []

for name in names:

 counter = 0

 for klass in parallel:

   for person in klass:

     if person == name:

       counter += 1

       break

 presence.append((name,counter))

for name in presence:

 print(name[0],'-',

       'встречаются во всех классах данной параллели' if name[1] == len(parallel)

       else 'есть только в некоторых классах' if name[1] != 0

       else 'не встречаются ни в одном классе')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика