(в паскале надо сделать)«карусель»карусель – одна из популярных форм проведения командных соревнований по решению .всем , участвующим в карусели, предлагаются в строгом порядке одни и те же , которые необходимо решить в установленное время. система подсчета такова, что доминирующим фактором является не количество решенных , а длины последовательностей правильных решений.начисление происходит согласно следующей схеме: первая стоит 3 ; если к дан верный ответ, то команда получает ее стоимость, а следующая будет стоить на 1 больше; если на дан неверный ответ, то команда получает за решение 0 , а следующая будет стоить на 3 меньше, но не менее 3 .вам требуется написать программу, которая по результатам ответов команды определит итоговый .первая строка входных данных содержит натуральное число n – количество в карусели (n ≤ 105). во второй строке расположены n цифр 0 или 1, разделенные пробелом; i-я цифра соответствует корректности ответа команды на i-ю (0 – неверный ответ, 1 – верный ответ).

korekhova1986super korekhova1986super    2   20.05.2019 12:47    6

Ответы
NeZnayVsego NeZnayVsego  01.10.2020 00:45

program raf105;

var

 s,s2: string;

 i,j,n,price,points: integer;

begin

write('Количество задач в карусели: ');

readln(n);

write('ответы команды: ');

readln(s);

for i:=1 to length(s) do

 if s[i]<>' '

   then s2:= s2 + s[i];

price:= 3;

for i:=1 to length(s2) do

begin

 if s2[i]='1'

   then begin

     points:= points + price;

     price:= price + 1;

   end

   else for j:=1 to 3 do

     if price > 3

       then price:= price-1;

end;

writeln('Итоговый : ',points);

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика