В Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 9. Программа получает на вход числа в последовательности, ввод чисел осуществляется до тех пор, пока не будет введён 0. В последовательности всегда имеется число, оканчивающееся на 9.
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести одно число: количество чисел, оканчивающихся на 9.
Пример работы программы:
Входные данные
19
29
24
0
Выходные данные
2​

Айла2010 Айла2010    2   18.05.2021 10:19    6

Ответы
olga88888888888888 olga88888888888888  17.06.2021 21:19

s = 0

for i in range(0, 1000):

    a = input()

    if int(a) != 0:

        if str(a[-1]) == '9':

            s += 1

        if int(a) >= 30000:

            print('Слишком большое число!')

    else:

        break

print(f'Всего чисел: {s}.')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика