В массиве хранится информация о стоимости книг . Составить программу, которая выводит на экран номера книг, которые стоят ниже средней стоимости всех этих книг. В C++

эмилисенок2 эмилисенок2    3   18.05.2020 22:09    7

Ответы
evika8444 evika8444  14.10.2020 23:22

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   ll n;

   cin >> n;

   ld a[n],sum = 0;

   for(ll i = 0; i < n; i++){

       cin >> a[i];

       sum += a[i];

   }

   ld av = sum/n;

   for(ll i = 0; i < n; i++)

       if(a[i] < av)

           cout << i+1 << " ";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика