В массиве А(N;N) определить сумму элементов, расположенных в четных и нечетных строках. Вывести массив и обе суммы. Написать программу на C++.

lmarki2003 lmarki2003    3   26.02.2021 11:59    2

Ответы
viktoriag373 viktoriag373  28.03.2021 12:02

Код на C++:

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

   srand(time(NULL));

   unsigned long S = 0;

   const int N = 10; //Для изменения массива изменять это число

   int A[N][N];

   for (int i = 0; i < N; i++)

   {

       for (int j = 0; j < N; j++)

       {

           A[i][j] = rand() % 100;

           cout << A[i][j] << " ";

       }

       cout << endl;

   }

   for (int i = 0; i < N; i += 2)

   {

       for (int j = 0; j < N; j++)

       {

           S += A[i][j];

       }

   }

   cout << endl << "Sum of even lines " << S << endl;

   S = 0;

   for (int i = 1; i < N; i += 2)

   {

       for (int j = 0; j < N; j++)

       {

           S += A[i][j];

       }

   }

   cout << endl << "Sum of odd lines " << S << endl;

   return 0;

}

Объяснение:

Я не знаю, какой размер у массива, но для изменения размера массива надо изменять значение константы N в коде. В первом вложенном цикле мы записываем случайное число от 0 до 99 и сразу же выводим на экран. Потом мы при первого цикла с шагом 2 (0, 2, 4, 6...) находим сумму четных строк. Второй массив для нечетных строк

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика