Условие
напишите программу, которая считает три числа и большее из них уменьшит на 5.

формат входных данных
вводится три различных целых числа a, b, c (−230≤a,b,c≤230−1).
формат выходных данных
требуется вывести новые значения этих чисел.
входные данные выходные данные
10 11 12
10 11 7
42 13 6
37 13 6
с++

311020029332 311020029332    3   01.11.2019 10:32    33

Ответы
Dumbass1007 Dumbass1007  19.01.2024 12:16
Привет! Как школьный учитель, я с радостью помогу тебе разобрать эту задачу по программированию.

Для решения этой задачи воспользуемся языком программирования C++. Вот подробный алгоритм решения:

1. Нам необходимо считать три различных целых числа a, b, c с клавиатуры.
2. Затем, нужно найти наибольшее число из трех введенных значений. Для этого сравним каждое число с другими двумя, используя конструкцию if-else.
3. Если a больше b и a больше c, то a является наибольшим числом.
4. Если b больше a и b больше c, то b является наибольшим числом.
5. Если ни одно из условий выше не выполняется, то c является наибольшим числом.
6. Когда мы нашли наибольшее число, уменьшим его значение на 5, вычитая 5 из найденного числа.
7. Выведем новые значения трех чисел a, b, c на экран.

Вот пример программного кода, решающего данную задачу на C++:

```cpp
#include
using namespace std;

int main() {
int a, b, c;

// Вводим значения трех чисел
cin >> a >> b >> c;

// Находим наибольшее число и уменьшаем его на 5
if (a > b && a > c) {
a -= 5;
} else if (b > a && b > c) {
b -= 5;
} else {
c -= 5;
}

// Выводим новые значения трех чисел
cout << a << " " << b << " " << c << endl;

return 0;
}
```

Теперь, если мы введем числа 10, 11, 12, программа выведет значения 10, 11, 7, так как 12 является наибольшим числом и мы уменьшили его на 5. Точно так же, если мы введем числа 42, 13, 6, программа выведет значения 37, 13, 1.

Надеюсь, что это решение понятно и поможет тебе понять, как решить данную задачу! Если у тебя возникнут еще вопросы, не стесняйся задавать их.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика