Уровень c. напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. уровень d (на дополнительную оценку, не обязательная). напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

ольга1716 ольга1716    3   24.08.2019 02:20    22

Ответы
sludkov sludkov  05.10.2020 15:46
Уровень C

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int maxdigit = 0;
    while (n > 0) {
        int digit = n % 10;
        if (digit > maxdigit)
            maxdigit = digit;
        n /= 10;
    }
    cout << maxdigit;
    return 0;
}

Уровень D
#include <iostream>

using namespace std;

int main(){
    int n;
    cin >> n;
    int prev = -1;
    while (n > 0) {
        int digit = n % 10;
        if (digit == prev) {
            cout << "YES";
            return 0;
        }
        prev = digit;
        n /= 10;
    }
    cout << "NO";
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика