Уровень a. напишите программу, в которой сортировка выполняется «методом камня» – самый «тяжёлый» элемент опускается в конец массива.

nastyaozernova nastyaozernova    3   27.08.2019 16:30    6

Ответы
zuzin77 zuzin77  05.10.2020 23:03
Var a:array[1..10000] of integer;
n,i,j,k,t:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
j:=n;
repeat
k:=j;
j:=0;
for i:=1 to k-1 do
if a[i+1]j:=i;
t:=a[i];
a[i]:=a[i+1];
a[i+1]:=t;
for t:=1 to n do
write(a[t],' ');
writeln;
end;
until j=0;
if k=n then
writeln(0); //Если перестановок не было, программа выводит только число 0. Если эта команда не нужна, можешь ее убрать
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика