Уровень A. Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.(ошибка времени исполнения)

var
a, b, c: integer;
d: text;
begin
assign(d,'input.txt');
reset(d);
c:=0;
b:=0;
while not eof do
begin
readln(d,a);
c:= c + a;
b:= b + 1;
end;
close(d);
assign (d,'output.txt');
rewrite(d);
write(d,c/b);
close(d);
end.

даник293 даник293    2   14.04.2020 09:27    22

Другие вопросы по теме Информатика