умоляю! составить программу на языке програмирования паскаль. 1) пойдет ли сундук с соровищами со сторонами а,в,с в иллюминатор затонувшего корабля диаметром д. 2) имеется треугольник с координатами(0,0)(5,0)(0,5). попадает ли точка а(х,у) внутрь либо на границы этого треугольника. ответ вывести в форме да или нет.

artem880 artem880    2   24.06.2019 18:30    8

Ответы
Vindrosel Vindrosel  20.07.2020 08:04
Var
  a,b,c,d,x,y:real;
begin
  Write('Введите размеры сторон сундука -> '); Readln(a,b,c);
  Write('Введите диаметр иллюминатора -> '); Readln(d);
  if a<b then begin
    x:=a;
    if b<c then y:=b else y:=c
  end
  else begin
    x:=b;
    if a<c then y:=a else y:=c
  end;
  if (sqr(x)+sqr(y)<sqr(d)) then Writeln('Сундук можно вытащить')
  else Writeln('Сундук нельзя вытащить')
end.

Тестовое решение:
Введите размеры сторон сундука -> 3 5 3.99
Введите диаметр иллюминатора -> 5
Сундук можно вытащить

**********************
Условие попадания точки A(x,y) внутрь треугольника описывается как
\begin {cases} x\ge 0 \\ y\ge 0 \\ y\le 5-x \end {cases} \Rightarrow \ (x\ge0) \land (y\ge0) \land (y\le 5-x)

var
  x,y:real;
begin
  Write('Введите координаты x и y точки -> '); Readln(x,y);
  if (x>=0) and (y>=0) and (y<=5-x) then Writeln('Да')
  else Writeln('Нет')
end.

Тестовое решение:
Введите координаты x и y точки -> 3 2.5
Нет

Введите координаты x и y точки -> 2.1 2.8
Да
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика