Умоляю, с паскалем 1) вычислить оптимальный вес по формуле рост-100 (фактический вес v и рост h вводятся пользователем) и выдать одно из сообщений: - у вас идеальный вес; - вам нужно похудеть на n кг (n вывести); - вам нужно поправиться на n кг (n вывести). 2)составить программу, которая бы по последней цифре многозначного числа выдавала бы одно из сообщений: число не делится ни на 2, ни на 5 число делится только на 2 число делится только на 5 число делится и на 2, и на 5.

krnshlpn krnshlpn    3   01.06.2019 17:10    4

Ответы
1234567890640 1234567890640  02.07.2020 19:26
1)
var v,h,i:real;
begin
readln(v);
readln(h);
i:=h-100;
if v=i then writeln('у вас идеальный вес') else 
if v>i then writeln('вам нужно похудеть на ', v-i,' кг ') else
writeln('вам нужно поправиться на ', i-v,' кг ');
end.

2)
var a:string;
b:integer;
begin
readln(a);
b:=strtoint(a[length(a)]);
if (b mod 2 <> 0) and (b mod 5 <> 0) then writeln('число не делится ни на 2, ни на 5');
if (b mod 2 = 0) and (b mod 5 <> 0) then writeln('число делится только на 2');
if (b mod 2 <> 0) and (b mod 5 = 0) then writeln('число делится только на 5');
if (b mod 2 = 0) and (b mod 5 = 0) then writeln('число делится и на 2, и на 52');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика