, у меня экзамен. Язык программирования - Python.

1 Уровень

Задача 1 –

Пользователь должен ввести логин и пароль. Длина логина от 5 до 10
символов. Длина пароля не менее 8 символов. Спрашивать у пользователя
логин, пока он не введет подходящий. Только после этого спросить пароль.
Спрашивать пароль, пока он не введет подходящий.

Задача 2 –

Напишите программу, которая 5 раз запрашивает у пользователя границы
диапазона и выводит на экран подходящее целое случайное число в данном
диапазоне.

Задача 3 –

Напишите программу, которая 5 раз запрашивает у пользователя границы
диапазона и выводит на экран подходящее целое случайное число в данном
диапазоне.

Задача 4 –

1. Пользователь вводит строку не менее 15 символов (проверить на эту
минимальную длину и при несоблюдении выдать ошибку)
2. Выведите 2 предпоследних символа этой строки
3. Выведите 5 символ этой строки
4. Выведите первые 8 символов этой строки
5. Выведите всю строку, кроме последних трех символов

Задача 5 –

• Создайте список names из 10 имен
• Создайте список numbers из 15 целых чисел
• Выведите имена из списка names с четными индексами
• Выведите числа из списка numbers, которые больше 10

Урлатоп Урлатоп    1   11.04.2021 17:01    12

Ответы
krejzin krejzin  11.05.2021 17:03

ответ: См. снимок экрана (код в объяснении)

Объяснение:

from getpass import getpass

from random import randint

def task1():

   while True:

       log = input('Login: ')

       if len(log) >= 5 and len(log) <= 10:

           break

   while True:

       pswrd = getpass('Password: ')

       if len(pswrd) >= 8:

           print('Logged in succesfully!')

           break

def task2():

   for i in range(5):

       a = int(input("Enter the start: "))

       b = int(input("Enter the end: "))

       print(randint(a, b))

def task4():

   s = input("Enter the string: ")

   if len(s) < 8:

       quit()

   print('1.', s[-3:-1])

   print('2.', s[4])

   print('3.', s[:8])

   print('4.', s[:-3])

def task5():

   names = ['Liam', 'Noah', 'Oliver', 'William', 'Elijah',

            'James', 'Benjamin', 'Lucas', 'Mason', 'Ethan']

   numbers = []

   for i in range(15):

       numbers.append(randint(1, 100))

   for j in range(0, 10, 2):

       print(names[j])

   for k in range(15):

       if numbers[k] > 10:

           print(numbers[k])


, у меня экзамен. Язык программирования - Python. 1 Уровень Задача 1 – Пользователь должен ввести л
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика