Турбо паскаль! факториалом числа m называется произведение натуральных чисел от 1 до m. m! =1*2*3*..*m; 4! =1*2*3*4=24. требуется написать программу, которая подсчитывает количество факториалов между n и k(включительно). формат входа данных: на вход подается два натуральных числа n и k, записанные через пробел. (1

swietajakubiak swietajakubiak    3   14.08.2019 08:00    4

Ответы
SakuraHarunoo SakuraHarunoo  04.10.2020 18:10
Var n,k,fact:int64;
c,i:longint;
Begin
readln(n,k);
fact:=1;
i:=2;c:=0;
while(fact<=k) do
Begin
if (fact>=n)and(fact<=k) then inc(c);
fact:=fact*i;
inc(i);
end;
writeln(c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика