Требуется поменять местами первый элемент массива с максимальным. входные данные в первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. во второй строке n чисел — элементы массива (целые числа, не превосходящие по модулю 1000). выходные данные вывести получившийся массив. если максимальных элементов несколько, требуется поменять первый из них.

elizavetaivlic elizavetaivlic    1   04.07.2019 10:40    18

Ответы
аникдим аникдим  28.07.2020 06:51
Var a:array[1..1000] of integer;
n,i,im,max:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
writeln;
max:=a[1];im:=1;
for i:=1 to n do
if a[i]>max then 
begin
max:=a[i];
im:=i;
end;
a[1]:=a[1]+a[im];
a[im]:=a[1]-a[im];
a[1]:=a[1]-a[im];
for i:=1 to n do
write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика