Требуется отсортировать массив по неубыванию методом "пузырька". в первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. во второй строке nчисел – элементы массива (целые числа, не превосходящие по модулю 1000). на с++ !

kozlovadasa52 kozlovadasa52    2   04.06.2019 06:00    10

Ответы
Людина5 Людина5  05.07.2020 09:54
A:array[1..1000] of integer;
i, k, z, n, j:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n-1 do
for j:=1 to n-i do
if a[j]>a[j+1] then begin
z:=a[j]; a[j]:=a[j+1]; a[j+1]:=z; end;
for i:=1 to n do
writeln(a[i]);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика