Требуется написать программу на языке паскаль или бейсик, которая будет выводить на экран максимальное значение из трех вводимых с клавиатуры чисел.

DanyNeifeld DanyNeifeld    1   10.03.2019 01:10    1

Ответы
Артёмка99999999 Артёмка99999999  06.06.2020 23:25

uses crt;
var a,b,c:integer;
begin
clrscr;
readln(a,b,c);
if (a>b) and (a>c) then writeln('Max chislo = ',a);
if (b>a) and (b>c) then writeln('Max chislo = ',b);
if (c>b) and (c>a) then writeln('Max chislo = ',c);
readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
azizplay07 azizplay07  06.06.2020 23:25

program max_chislo;

var

  a,b,c:integer;

begin

  write ('Введите три числа через пробел');read(a,b,c); readln;

  if (a>b) and (a>c) then write('максимальное число = ',a);  

  if (b>a) and (b>c) then write('максимальное число = ',b)

    else write ('максимальное число = ',c);

  readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика