tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Требуется написать программу
Требуется написать программу на c++ даны натуральные числа n и m (0≤m≥9). найти сумму первых m цифр числа n. если цифр в n меньше, чем m, то считать недостающие цифры равными 0.
myrjyffiyfukfkufkyf
3 20.08.2019 10:30
2
Ответы
nacteylka
20.08.2020 12:29
#include <iostream>
using namespace std;
int main()
{
int n, m, n1;
int s=0;
int k=0;
cout << "n = ", cin >> n, cout << "\n";
cout << "m = ", cin >> m, cout << "\n";
n1 = n;
while (n1 > 0){
s += n1 % 10;
n1 = n1 / 10;
k++;
}
n1 = n;
for (int i=1; i<=k-m; i++) {
s -= n1 % 10;
n1 = n1 / 10;
}
cout << "s = " << s << "\n";
return 0;
}
Пример:
n = 34568
m = 4
s = 18
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Eddyp
17.12.2019 14:25
Для шифровки каждой буквы слова используется двузначное число.известно,что буква ,,к кодируется числом 20.среди слов ,,торт , ,,ёжик , ,,станок , ,,беседа есть слова, кодируемые...
musiclove2
17.12.2019 14:27
Visual basic! написать процедуру: 1) вычислить сумму элементов массива x(m) 2)те из элементов массива y(n), значения которых равны произведению двух предыдущих умножить сумму элементов...
Dasha78906543
17.12.2019 14:29
Определить, что будет выведено в результате выполнения следующей программы. program b78; var i, k: integer; a: array [1..7] of integer; begin for i: 1 to 7 do a[i]: = i*3; if a[i]...
хочуха04
17.12.2019 14:31
Выполнить в mathcad: рассчитать выражения в соответствии с вариантом, используя встроенные функции. получите таблицу значений функции на интервале [a, b] с шагом h. ответ должен...
YaroslavShevchuk
06.05.2020 14:56
Решите Запишите значение переменной a, полученное в результате работы следующей программы. var a, b: real; begin a := 6; b := 2; b := b+ 2 * a; a := a / 2 + 3 * b; writeln (a);...
Fatima82
06.05.2020 14:56
Кто знает С сделать задание...
RezinkaLIVE
06.05.2020 14:55
Әшкәре элементтер тобының қай түрі көрсетілген? * Please...
bur5645
06.05.2020 14:55
Треба замалювати в зошит форму з нанесеними компонентами та записати код програми, коментуючи за що відповідає кожна команда коду.Якщо ви намалювали форму і добавити компоненти,...
itpediaigor
06.05.2020 14:55
Почему при цифровом кодировании сигнала часть информации теряется?...
витно
06.05.2020 14:55
написать код на Pascal. Заранее благодарю за поддержку 3 Зд. 1 Сформировать массив В(4,6) у которого элементы первой стоки равны единицы, второй строки равны двум, третьей строки...
Популярные вопросы
Жабка,сумний метелик,вирішила втішити, хотіла з їсти,не дістала язиком,засмутилася,полетіла....
2
Які засоби використовував для досягнення цілей князь святослав...
2
Как будет на казахском время: 15: 00 3: 00 18: 00 6: 00 21: 00 9: 00 12: 00 20:...
3
Неопределенная форма глагола пойдёшь...
2
Как называется величина, характеризующая интервалы между пульсовыми волнами?...
3
Укажите все изобразительно-выразительные средства в тексте: (1)на даче темно,...
3
Подумайте, с какими пороками современного человечества необходимо бороться современному...
1
(5)тексты в научном стиле о турции и о языке(турецкий) ...
2
Из 9000 сотовых телефонов третья часть имела гарантию 3 года, остальные 1 год....
2
Как на сказать стоять за дверью ( человек стоит внутри здания, за дверью)здесь...
1
using namespace std;
int main()
{
int n, m, n1;
int s=0;
int k=0;
cout << "n = ", cin >> n, cout << "\n";
cout << "m = ", cin >> m, cout << "\n";
n1 = n;
while (n1 > 0){
s += n1 % 10;
n1 = n1 / 10;
k++;
}
n1 = n;
for (int i=1; i<=k-m; i++) {
s -= n1 % 10;
n1 = n1 / 10;
}
cout << "s = " << s << "\n";
return 0;
}
Пример:
n = 34568
m = 4
s = 18