Требуется написать программу, которая будет выполнять действия описанные ниже. желательно с комментированием.(visual studio, на c#) символы и их коды. формирование строк 1.22. дана строка, изображающая целое положительное число. вывести сумму цифр этого числа. 1.23. дана строка, изображающая арифметическое выражение вида «±±…±», где на месте знака операции «±» находится символ «+» или «–» (например, «4+7–2–8»). вывести значение данного выражения (целое число). 1.24. дана строка, изображающая двоичную запись целого положительного числа. вывести строку, изображающую десятичную запись этого же числа.

69699696 69699696    3   29.09.2019 07:10    34

Ответы
lddld lddld  09.10.2020 02:13

Переменную строки буду называть \texttt{str}.

1.22.

\texttt{Console.WriteLine(str.Select(t = int.Parse(t.ToString())).Sum());}

1.23.

\texttt{Console.WriteLine(Regex.Matches(str, @"[+-]*}\char`\\\texttt{d+")}\\\texttt{{ }{ }{ }{ }.Cast()}\\\texttt{{ }{ }{ }{ }.Select(t = t.Value.Replace("+", ""))}\\\texttt{{ }{ }{ }{ }.Select(int.Parse)}\\\texttt{{ }{ }{ }{ }.Sum());}

1.24.

\texttt{Console.WriteLine(Convert.ToInt32(str, 2).ToString());}

Потребуется использовать

\texttt{using System.Linq;}

\texttt{using System.Text.RegularExpressions;}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика