Требовалось написать программу вычисления факториала числа n(n! =1*2*..*n). программист торопился и написал программу неправильно. ниже фрагмент его программы, в которой содержится 5 ошибок: k: =1; f: =0; while k f: =f*k; k: =k+1; найдите ошибки. допишите необходимые операторы и выполните программу на компьютере. (проверка 5! =120, 6! =720).

avrika avrika    2   27.06.2019 21:30    5

Ответы
DDaVV DDaVV  22.07.2020 09:54
Язык С++:
#include <iostream>
using namespace std;
void main(){
int n=5, k, f=1; //f - факториал, n - число, фак-ал которого нужно вычислить
while(k<=n){
f*=k;
k++;
}
cout<<"Факториал числа "<<n<<" равен : "<<f<<endl;
}
Pascal:
program z4;
var n, k, f: integer;
begin
write('Введите число, для которого нужно вычислить факториал : ');
readln(n);
k:=1;
f:=1;
while(k<=n)
begin
f:=f*k;
k:=k+1;
end;
writeln('Факториал равен : ', f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика