Требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры

krashakova krashakova    1   31.05.2019 11:00    3

Ответы
Adashok Adashok  01.07.2020 22:20
Var a,b:integer; x:real;
begin
readln (a,b);
x:=abs(b/a);
writeln (x:0:2);
end.

АБС это модуль, но я могу и ошибаться, тогда
var a,b:integer; x:real;
begin
readln (a,b);
If a<0 then a:=a*(-1);
If b<0 then b:=b*(-1);
x:=abs(b/a);
writeln (x:0:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика