Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел, а и b хотя бы одно четное. Была написана следующая программа:

var a, b: integer;

begin

readln(a, b);

a := a mod 2;

if a > 0 then b := b mod 2;

if b > 0 then

writeln ('четных чисел нет')

else

writeln ('четное число есть');

end.

Известно, что программа написана с ошибками. Последовательно выполните три задания:

приведите пример таких чисел, а, b, при которых программа неверно решает поставленную задачу;
укажите, как, по вашему мнению, нужно доработать программу (не используя сложные условия), чтобы не было случаев ее неправильной работы;
укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала один условный оператор со сложным условием.

annvs1 annvs1    2   15.05.2020 06:17    19

Другие вопросы по теме Информатика