только программу C++ В григорианском календаре года нумеруются числами 1, 2, 3 и т.д. - это года “нашей эры”.
Предшествующие года называются “первый год до нашей эры”, “второй год до нашей эры” и т.д. Будем
обозначать года нашей эры положительными числами, а года до нашей эры — отрицательными. При
этом года с номером 0 не существует, то есть нумерация лет выглядит так: ..., −3, −2, −1, 1, 2, 3, ... В
летописях написано, что какое-то событие произошло в году номер A, а другое событие произошло
спустя n лет после первого события (или за n лет до первого события). Определите, в каком году
произошло второе событие.
Формат входных данных
Первая строка входных данных содержит число A — год, в котором произошло первое событие. Вторая
строка содержит число n. Если n > 0, то второе событие произошло через n лет после первого события,
а если n < 0, то второе событие произошло за |n| лет до первого события. Оба числа могут быть как
положительными, так и отрицательными.
Формат выходных данных
Программа должна вывести одно целое число — номер года, в который произошло второе событие.

Максим5955 Максим5955    1   24.10.2020 09:11    6

Ответы
ЮлияСтоянова ЮлияСтоянова  23.11.2020 09:12

#include <iostream>

using namespace std;

int main(){

 

long long int A;

std::cin >> A;

long long int n;

std::cin >> n;

long long int Answer = A + n;

 

if(A >= 0 && Answer <= 0 || A <= 0 && Answer >= 0){

 if(A >= 0 && Answer <= 0){

  Answer--;

 }else{

  Answer++;

 }

}

 

std::cout << Answer;

 

return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика