Только для ! составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. на экран должен быть выведен результат выполнения соответствующего арифметического действия. для ввода знака использовать переменную типа char.

кар91 кар91    1   17.07.2019 10:20    8

Ответы
Артур15051505 Артур15051505  03.10.2020 06:19
Var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
ПОКАЗАТЬ ОТВЕТЫ
dariaa3 dariaa3  03.10.2020 06:19
Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика