Тест по теме «Язык программирования Паскаль»

1. Для отделения операторов друг от друга в языке Паскаль используют:
а) пробел; б) двоеточие; в) запятую; г) точку с запятой.

2. Из предложенных заголовков программы правильным является:
а) Program сумма; в) programm сумма;
б) programm summa; г) program summa.

3. Для вывода результатов в языке программирования Паскаль используют ключевое слово:
а) VAR; б) READ; в) BEGIN; г) WRITE.

4. Квадратный корень числа вычисляет функция:
а) SQRT (X); б) SQR (X); в) ABS (X); г) INT (X).

5. Конечное значение переменной У в результате выполнения следующих действий:
У:=5;
Х:=2;
У:=(У-2*Х)/2+Х
будет равно:
а) 0,5; б) 2; в) 2,5; г) 5.

6. В результате выполнения программы

program my_klass;
begin
write (25/2,5*2);
writeln (‘улыбок’);
end.

мы увидим на экране:
а) 5 улыбок; в) 5
улыбок;
б) 25 улыбок; г) 25
улыбок.

7. В данном фрагменте программы

program error;
begin
summa:=25-14;
end.

ошибкой считают:
а) некорректное имя программы;
б) длинное имя переменной;
в) не определенное имя переменной;
г) запись арифметического выражения.

8. Значения одномерного массива задаются с цикла:
for i:=1 to 5 do B[i]:= 5+i;
В результате значение В[3] будет равно:
а) 9; б) 8; в) 7; г) 6.

9.

for i:=1 to 10 do begin
if a[i]>0 then a[i]:=a[i]/2
else a[i]:=i;
end;

произойдет следующее:
а) положительные значения элементов массива увеличатся вдвое, а отрицательные заменятся значениями индекса;
б) положительные значения элементов массива уменьшатся вдвое, а отрицательные заменятся значениями индекса;
в) отрицательные значения элементов массива увеличатся вдвое, а положительные заменятся значениями индекса;
г) отрицательные значения элементов массива уменьшатся вдвое, а положительные заменятся значениями индекса.

10. В результате выполнения фрагмента программы

writeln (‘Новый массив’);
for i:=1 to 20 writeln (a[i]);
end.

произойдет следующее:
а) сформируется новый массив;
б) новый массив распечатается;
в) распечатаются только индексы;
г) сформируются только индексы.

gxgvxf gxgvxf    3   22.12.2020 12:09    41

Другие вопросы по теме Информатика