Тема: pascal. циклы 1)составить программу подсчета суммы нечетных делителей,кратных трем,натурального числа n 2) составить программу,вычисляющую x^n,где n-целое положительное число. 3) одноклеточная амеба каждые 3 часа делится на 2 клетки.определить,сколько амеб будет через 3,6,9, часа.

ДЭМКО ДЭМКО    3   07.06.2019 01:20    2

Ответы
m1a2c3s4i5m6a7 m1a2c3s4i5m6a7  06.07.2020 23:04
1
var n,s,i:integer;
begin
readln(n);
for i:=3 to n do
  if (n mod i=0) and (i mod 3=0) and (i mod 2>0) then
    s:=s+i;
writeln ('ответ: ',s);
end.

2
var
  n,i:integer;
  x,y:real;
begin
readln(x,n);
y:=1;
for i:=1 to n do y:=y*x;
writeln (x,'^',n,'=',y);
end.

3
var n,i:integer;
begin
n:=1;
writeln('Часы ',' Кол-во');
while i<25 do
  begin
  writeln(i:3,n:6);
  n:=n*2;
  i:=i+3;
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика