Тема: одномерные массивы, написать программу использую rite, riteln ; все элементы кратные трем делятся на три, остальные умножаются на 3.

аленка1опр аленка1опр    3   01.06.2019 17:10    3

Ответы
Const N=...;//указываешь количество элементов массива
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do 
readln(a[i]);
for i:=1 to N do begin
 if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика