Св "паскале"! 1. составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. проверьте алгоритм трассировкой.(объясните за одно, что такое "трассировка") 2. дано целое число х и натуральное n. составьте алгоритм вычисления х^n. проверьте алгоритм трассировкой.

саша080706 саша080706    2   06.06.2019 03:10    4

Ответы
TolstoyLev TolstoyLev  06.07.2020 11:37
1)
var
    i, n, m: integer;

begin
    readln(n);
    for i := 1 to n do
        m := m + i;
    writeln('сумма всех натуральных чисел не превышающих ', n, ' - ', m);
end.

2)
var
    x, n, i, p: integer;

begin
    write('Число: ');
    readln(x);
    write('Степень :> ');
    readln(n);
    p := 1;
    for i := 1 to n do
        p := p * x;
    writeln('Результат: > ', p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика