tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сумма всех цифр в числе
Сумма всех цифр в числе вводимых пользователем, программа без while . паскаль , пример : число 127 значит сумма 10
Саша22877324516
3 16.09.2019 16:30
5
Ответы
Юлия111157
07.10.2020 20:19
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write('сумма: ',ReadInteger('Введите число: ').ToString().Select(x->x.ToDigit()).Sum());
end.
ПОКАЗАТЬ ОТВЕТЫ
Oleg12875
07.10.2020 20:19
//Pascal
var x, Sum: longint;
begin
write('Число = ');
readln(x);
while (x<>0) do
begin
Sum := Sum + (x mod 10);
x := x div 10;
end;
writeln('Сумма цифр = ', Sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Artem228133
03.12.2020 13:45
Задание для самостоятельной работы: составить таблицу кодов идентификации процессоров по вариантам (Intel/АМD)составить таблицу кодов идентификации процессоров Тип/Семейство/Модель/Процессор...
LilyaDolz
13.08.2019 18:10
Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от -50 до 50. (паскаль)...
olga638
30.04.2020 13:25
ТЕСТ Цикл з передумовою В яких із наведених операторів циклу тіло циклу не виконається жодного разу? так ні Х:=5; Whіle Х 5 do X := X+1; Х := 10; Whіle Х = 10 do X :=...
maximbond04
30.04.2020 13:25
Для хранения каждого из чисел IP адреса выделяют по 8 битов...
daurmukhtar99
30.04.2020 13:25
Для целочисленного массива определить, образуют ли его элементы неубывающую последовательность. Написать в C++...
Elkhadi54Skorpion
27.05.2019 05:00
Вычислите периметр треугольника авс, если ав=0,8(ас+вс)=12см...
AzaLin1
27.05.2019 05:00
Что больше и на сколько : шестая часть от 102 или восьмая часть от 128...
nikolsonr
27.05.2019 05:00
Дать характеристику сущ. и прил. впредложении мама приготовила зелёные щи и овощное рагу...
koooool
27.05.2019 05:00
Одночлен к стандартному виду: 0,5ху *(-2.4y)...
mary357vozd80s
27.05.2019 05:00
Последствия колониализма положительные и отрицательные последствия?...
Популярные вопросы
X+3*(1-2x)=23 решите кто решит поблагадарю...
2
Характеристика героя татьяна (евгений онегин пушкин а.с.)...
3
Перевести alex and his sister like singing...
3
Напишите уравнения реакций,осуществляющие следующие превращения: a)...
2
Напишите реферат на тему обычаи казахского народа на казахском языке...
1
(мишутка собирает ягоды .каждый раз кладёт в горшочек 10 ягод затем...
2
Моторная лодка против течения реки 132км и вернулась в пункт отправления,затратив...
2
Сочинение на языке моя знаменитость вас будьте добрыми : d...
2
Подчеркнуть гласные в словах буквы,страница,лист,бумага...
1
Найти значение выражение: 1)-x+3y-z , при x=0,5; y=-0,9; z=-1,6 2)3x+y+2z...
3
//Версия 3.3, сборка 1611
begin
write('сумма: ',ReadInteger('Введите число: ').ToString().Select(x->x.ToDigit()).Sum());
end.
var x, Sum: longint;
begin
write('Число = ');
readln(x);
while (x<>0) do
begin
Sum := Sum + (x mod 10);
x := x div 10;
end;
writeln('Сумма цифр = ', Sum);
end.