Сумма ряда Напишите программу, соблюдающие данные условия

C клавиатуры вводится натуральное число n > 0, потом n чисел, каждое на новой строке.

Вычислите и напечатайте знакочередующуюся сумму ряда (первое число прибавить, второе вычесть, третье прибавть и т.д.) Например, для чисел 1,2,3,4 сумма будет следующей: 1 - 2 + 3 - 4 = -2.

Пример 1

Ввод Вывод

3

5

2

7

10

Пример 2

Ввод Вывод

2

3

3

0

Пример 3

Ввод Вывод

5

34

-87

35

65

-9

82

Примечания

В задаче нельзя использовать условный оператор.

ladychoco ladychoco    1   22.10.2020 18:35    145

Ответы
roleman roleman  21.11.2020 18:36

mstr = ""

for i in range(0, int(input())):

   while i % 2 == 0:

       mstr += "+" + input()

       break

   while i % 2 != 0:

       mstr += "-" + input()

       break

print(eval(mstr))

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика