Студенту составить программу через pelles введите одномерный целочисленный массив, состоящий из 10-ти элементов. найдите сумму отрицательных элементов массива

оля20121 оля20121    1   09.11.2019 12:23    6

Ответы
olga000064 olga000064  10.10.2020 12:03

#include <stdio.h>

#include <stdlib.h>

int main()

{

int Arr[10]={};// Создаем массив состоящий из 10 элементов.

int Summ = 0;// Переменная в которой будут храниться сумма отрицательных элементов массива

printf("Vvedite 10 elementov massiva \n");

for (int i = 0; i < 10; i++)

{

 

 scanf_s("%d", &Arr[i]);

 if (Arr[i] < 0)

 {

  Summ += Arr[i];

 }

}

printf("%d \n", Summ);

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Ангелина56533 Ангелина56533  10.10.2020 12:03

/

                           Online C Compiler.

               Code, Compile, Run and Debug C program online.

Write your code in this editor and press "Run" button to compile and execute it.

/

#include <stdio.h>

int main()

{

   int m[10];

   int otrsumm = 0;

   int i;

   for (i = 0; i < 10; i++)

       scanf("%d", &m[i]);

   for (i = 0; i < 10; i++)

       if (m[i] < 0){

           otrsumm += m[i];

       }

   printf("%d", otrsumm);

   return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика