Строки в стиле С •Написать программу, которая вводит символьный массив из 15-ти или
меньшего числа элементов и находит в нем символ с наименьшим ASCII-кодом

ваноумно ваноумно    1   31.01.2022 00:21    3

Ответы
dkuchanov1352 dkuchanov1352  31.01.2022 01:00

#include <stdio.h>

#include <windows.h>

#include <string.h>

#define _MAX_STRING_SIZE_ 15

int main()

{  

   SetConsoleCP(65001);

   

   char str [_MAX_STRING_SIZE_];

   scanf("%s", &str);

   int min = (int)str[0];

   for(int i = 0; i < strlen(str); i++)

       if((int)str[i] < min)

           min = (int)str[i];

   printf("%d", min);

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика