Срешением двух ! . нужно написать программу на паскаль, заранее, ! ) в двумерном массиве 5 x 5, заполненный случайными числами, найти количество положительных элементовдан двумерный массив a[n,n]. сформировать одномерный массив в, состоящий только их элементов главной диагонали.

mahamde mahamde    2   08.06.2019 01:00    3

Ответы
Мучений Мучений  07.07.2020 13:14
Var a: array[1..5,1..5] of integer;
pol,i,j:integer;
begin 
randomize;
for i:=1 to 5 do 
 for j:=1 to 5 do  a[i,j]:=random(100)-50;
for i:=1 to 5 do
  for j:=1 to 5 do  if a[i,j]>0 then inc(pol);
write(pol);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика