Спрограммой в паскале, дан массив из n чисел. определить количество чисел, превышающих число 5. найти сумму этих чисел. напишите программу.. (одномерный массив)

eshkeree1 eshkeree1    3   28.05.2019 21:40    2

Ответы
Andriy0101 Andriy0101  26.06.2020 16:53
Program arr;
var 
 ar : array[1..100] of Integer; 
 i, size, count, sum : Integer;
begin 
 Writeln('Введите размер массива');
 Readln(size); 
 if (size > 100) then begin 
  Writeln('Hазмер массива превышает 100 элементов. Программа будет завершена...');   
 Readln; 
 end 
 else begin 
  Writeln('Введите ', size, ' чисел');   
 for i:=1 to size do begin     
 readln(ar[i]);     
 if ar[i] > 5 then begin       
 Inc(count);       
 Inc(sum, ar[i]);     
 end;   
 end;   
 Writeln('Вы ввели ', i - 1, ' чисел из которых ', count, ' больше 5, а их сумма составляет ', sum);   
 Readln; 
 end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика