tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Спрограммой: дана сторона
Спрограммой: дана сторона равностороннего треугольника. найти площадь этого треугольника, его высоту, радиусы вписанной и описанной окружностей. в программе microsoft visual studio c#
никитоз5
3 09.06.2019 07:30
20
Ответы
Gggg25632
08.07.2020 06:51
[STAThread]
static void Main()
{
double a = double.Parse(Console.ReadLine());
double h, r, R, S;
h = Math.Sqrt(3) / 2 * a;
S = 0.5 * a * h;
r = (2 * S) / (3 * a);
R = Math.Pow(a, 3) / (4 * S);
Console.WriteLine("h = {0}", h);
Console.WriteLine("S = {0}", S);
Console.WriteLine("r = {0}", r);
Console.WriteLine("R = {0}", R);
Console.ReadKey(false);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
abeloglazova891
23.09.2019 09:58
Сор по информатика. кто нибудь...
яна15с
23.09.2019 09:53
Ученики 7 б класса после уроков ходят в кружки. кто-то ходит а программирование, кто-то на лего. сколько человек в 7 б классе, если в программирование ходят 19 человек, на...
2007arttt
02.03.2021 06:50
Определите при выборе синего цвета что выведет робот на монитор...
mari523
02.03.2021 06:52
Определите функцию ввода данных Input Print Math Boolean...
Lopkrtjvbbcx
02.03.2021 06:52
ответить письменно в тетради на вопросы: Какие операторы выбора ты знаешь? Напиши их структуру.Чем отличаются циклы с параметром от циклов с условием?Чем цикл с предусловием...
viktoriyabolgova
02.03.2021 06:53
Жам Что такое датчик цвета? Напиши наименования режимов датчика цвета....
gazizullinnafi
02.11.2020 19:27
Робот может перемещаться в четырех направлениях («С» — север, «З» — запад, «Ю» — юг, «В» — восток) и принимать три цифровые команды: 0 — продолжать движение, 1 — поворот налево,...
RSL1
02.11.2020 19:27
Расшифруй слова ,закодираванные в двоичном коде, используя таблицу ASCII...
djokerzcoziirem9
08.09.2019 19:50
Мальчик квант сделал свой собственный калькулятор, правда он может выполнять только 2 операции: 1. прибавить к числу единицу. 2. умножить число на 2. так, например число 5...
8Lisandra8
08.09.2019 19:50
Сообщение занимает 50 страниц по 20 строк, в каждой строке записано по 55 символов. сколько символов в сообщении?...
Популярные вопросы
Модуль напруженості електричного поля в точці де перебуває тіло заряду...
3
Точка a eдиничной окружности, соответствующей углу а , находится в третей...
1
Вычислить массу соли которая образуется при взаимодействии с02 объемом...
1
Чему равен x, напишите формулы из разряда sinx=1 x=pi/2+2pn,n принадлежит...
2
Будь ласка, іть! терміново потрібно на завтра.завдання: 1. налийте 1 пробірку...
2
Pascal (только начали проходить, простой алгоритм) написать программу,...
1
Найти сумму вида: -1+2+4-7-11+16+22+ для n элементов число n изначально...
2
Два кола мають зовнішній дотик.відстань між їх центрами 22 см.знайдіть...
1
7класс. есть ли гарантия, что правильно у вас?...
3
вас табиғи байлықты орынды жұмсау керек дегенді қалай түсінесіндер?...
1
static void Main()
{
double a = double.Parse(Console.ReadLine());
double h, r, R, S;
h = Math.Sqrt(3) / 2 * a;
S = 0.5 * a * h;
r = (2 * S) / (3 * a);
R = Math.Pow(a, 3) / (4 * S);
Console.WriteLine("h = {0}", h);
Console.WriteLine("S = {0}", S);
Console.WriteLine("r = {0}", r);
Console.WriteLine("R = {0}", R);
Console.ReadKey(false);
}