«Списки в Python» №1.На вход программе подается одна строка, состоящая из слов на английском языке, разделенных
пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого
слова в столбец.
№2.На вход программе подается одна строка, состоящая из слов на английском языке, разделенных
пробелами. Создайте из этой строки список слов, и выведите на экран первые две буквы каждого
слова в столбец.
№3На вход программе подается одна строка – натуральные числа, разделенные пробелами.
Отсортируйте список по возрастанию. Выведите результат на экран. Правда ли, что в списке
максимальный и минимальный элемент оканчиваются одной цифрой?

РевинаМелек РевинаМелек    2   30.12.2021 21:33    5

Ответы
123456qwe1234567 123456qwe1234567  30.12.2021 22:00

1)

s = str(input()).split()

for a in s:

   print(a[0] + a[1])

#нет проверки на то что длина слов больше 1

2)

условие то же что и в 1)

3)

s = list(map(int, str(input()).split()))

s.sort()

print(s)

if str(min(s))[len(str(min(s)))-1] == str(max(s))[len(str(max(s)))-1]:

   print('Правда')

else:

   print('Неправда')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика