Сpascal turbo. нужно написать программунаберите программу вычисления суммы s=x+x^2++x^n и проверьте ее работу при различных значениях x и натурального n

kirushinad1 kirushinad1    3   27.07.2019 23:30    1

Ответы
миша29112000 миша29112000  03.10.2020 14:47
Var
  s, cur: longint;
  x, n, i: integer;
begin
  write('x='); read(x);
  write('n='); read(n);
  cur := 1; s := 0;
  for i := 1 to n do begin
    cur := cur * x; 
    s := s + cur;
  end;
  writeln('sum=', s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика