tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Создать программу для перевода
Создать программу для перевода чисел из десятичной в двоичную систему счисления. Паскаль
Кари15142
1 19.05.2020 17:03
3
Ответы
Jyrtasa
06.08.2020 11:58
Имо, короче некуда:
function f (x:integer):string := x>0?f(x div 2)+(x mod 2).ToString:''; begin var x := ReadInteger; Write(f(x)); end.
Пример работы:
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
anfisachupina85
13.05.2020 14:00
Анимация мен кескіннің қайдай айырмашылығы бар көмек керек!...
polyaketoztt67
14.06.2019 00:10
Дано a=5c1.5 (16), b=642.25 (8). выполнить действие a+b ответ представить в 16-й системе счисления....
ghostridermen
14.06.2019 00:10
Доклад на тему обновление по (киньте инфу )...
Zhenyarishka1
14.06.2019 00:10
На аттракционе в парке развлечений 8 лампочек, каждая лампочка может светить только одним цветом или быть погашена. сколько различных комбинаций может высветиться на аттракционе?...
LoVE3223
14.06.2019 00:10
Получено сообщения информационный объем которого равен 512 битам чему равен этот объем в байтах...
vovaonuchko
14.06.2019 00:10
1)в каком устройстве компьютера производится обработка информации? а)клавиатура б)монитор с)внешняя память д)процессор 2)для получения на компьютере звука служит: а)звуковая карта...
romkagamernumbp0bv1q
17.04.2020 10:33
Информатика с программы кумир построить графики функций: y=-x y=2x+3 y=x*x*x ( именно кумир, а не чертёжник...
arsenpogosyan
07.05.2020 18:49
ЛЮДИ ДОБРЫЕ, КРАСАТУЛЕНЬКИ С ИНФОЙ Написать программу в паскале (тема строковый тип), которая запрашивает три строковые переменные: существительное, прилагательное и глагол, а затем...
nermine
07.05.2020 18:49
Информатика как сделать это в скретч...
israelyan87
21.04.2020 13:03
метилбутаноль+амиачный раствор оксида серебра...
Популярные вопросы
Яразобрал сомастоятельно слово язык и срадостью вам язык-.форм-язык.,нариц.,одуш.,мужской.р.,2ск.,ед.ч.,и.п....
3
Составь текст по опорным словам. мама, папа, работа, пылесос, радость, родители...
3
Почему эпохи, близкие к современности, мы изучаем подробнее, чем отдалённые?...
2
Крастениям, которые зимуют под снегом не сбрасывая листьев, относятся а) марьянник...
3
Словосочетание слышится издалека - это , примыкание или согласование?...
2
Составить 5 вопросов по сказке царевна-лягушка ) кто сделает тому огромное...
2
Выполните действие и сократите результат; 1) 5/18+4/18; 2) 25/34-8/34; 3) 3 13/45+6...
2
Составить 5 вопросов по сказке царевна-лягушка кто сделает тому огромное...
1
Нужно написать рассказ на тему жизнь общины...
2
Автомобиль за 1 ч 15 мин преодолел 25 % расстояния между двумя . за какое время...
3
Имо, короче некуда:
function f (x:integer):string := x>0?f(x div 2)+(x mod 2).ToString:''; begin var x := ReadInteger; Write(f(x)); end.Пример работы: