tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программы для
Составьте программы для вычисления следующих формул: а) z=3+x^2-3x^3; б) d=x(sin x+cos x^2+ixi);
saint6928
2 25.07.2019 20:50
8
Ответы
NastikLoVe22
03.10.2020 12:58
Программа:
var x,z,d:real;
begin
write('x = '); readln(x);
z:=3+x*x-3*x*x*x;
writeln('z = ',z);
d:=x*(sin(x)+cos(x*x)+abs(x));
writeln('d = ',d);
end.
Пример:
x = 3
z = -69
d = 6.68996923852557
ПОКАЗАТЬ ОТВЕТЫ
Sgff3
03.10.2020 12:58
//Задание a
var x,z:real;
begin
write('Введите Х ');
readln(x);
z:=3+sqr(x)-3*sqr(x)*x;
writeln('z = ',z);
end.
Тестовое решение:
Введите Х 12
z = -5037
// Задание б
var x,d:real;
begin
write('Введите Х ');
readln(x);
d:=x*(sin(x)+cos(x*x)+abs(x));
writeln('d = ',d:0:3);
end.
Тестовое решение:
Введите Х 28
d = 796.395
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
pupsikira2
26.03.2020 04:31
Проводилась двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и 24-битным разрешением. В результате был получен файл размером 4 Мбайт, сжатие данных не производилось....
арсен157
26.03.2020 04:25
Написать программу для вычисления длины и площади круга, радиус которого сгенерирован случайным образом (функция uniform (a,b))....
Ayannn
26.03.2020 04:24
Яку з фігур треба використати для складання алгоритму з повторенням в середовищі Scretch? 1. 2. 3. 4....
Yuliya0264
26.03.2020 04:21
Написать программы в ПАСКАЛЬ1. Найдите все двузначные числа, которые при умножении на 2 заканчиваются на 8.2. Найдите все трехзначные числа, которые при увеличении на 2 делятся...
edshabashenko
08.07.2019 17:50
Подскажите ! как переводить числа из 2 ичной системы в 10 чную и обратно? проходила уже эту тему, но подзабыла немного. если можно с примерами. заранее ....
nastiaUA
25.06.2019 03:30
Определить суму всех чисел кратных 3 из промежутка от 100 до 1000...
ДайОтвет2281
25.06.2019 03:30
Определить сумму всех чисел кратных 3 из промежутка от 100 до 1000...
Иришка9Класс
25.06.2019 03:40
Камень падает в колодец. известно время падения. вычислить глубину колодца. : в тетради выполнить этапы программирования 1-3, после этого написать программу расчета глубины...
Отлишник88
25.06.2019 03:40
При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы ш, к, о, л, а (таким образом, используется...
54526
25.06.2019 03:40
Контролирующая программа. предлагаеться 10 на сложение двух целых двузначных .числа случайным образом.каждый ответ комментируется -правильно или вы ошиблись.после выполнения...
Популярные вопросы
КТО ОТВЕТИТ ДО 14:10-14:00 РАЗБЕРИТЕ СЛОВА ПО СОСТАВУ: ЗАЯЧЬЕМУ, МЕДВЕЖЬЕЙ,ОВЕЧЬЯ,ЧЕЛОВЕЧЬЯ,ВОЛЧЬЯ,ЛИСЬЕ,СОБОЛЬЕЙ....
2
Чому Спарта перетворилася на єдиний державний табір...
1
с алгеброй Стандартный вид числа...
1
У скляній трубці вода піднялася на 20 мм. Як підніметься в тій самій трубоці...
1
Твардовский, стих весенние строчки идея, кратко...
2
Страны Восточной Африки, особенно Сомали и Эфиопия, страдают от многолетней...
3
Яка маса 10% розчину натрій гідроксиду витратиться на взаємодію з оцтовою...
3
Каким величинам могут быть равны смежные углы? 42° и 136°93° и 87°54° и...
1
Витя и Аня собирают коллекцию карточек с изображением героев мультфильмов....
2
Read text and put 10 questions...
1
var x,z,d:real;
begin
write('x = '); readln(x);
z:=3+x*x-3*x*x*x;
writeln('z = ',z);
d:=x*(sin(x)+cos(x*x)+abs(x));
writeln('d = ',d);
end.
Пример:
x = 3
z = -69
d = 6.68996923852557
var x,z:real;
begin
write('Введите Х ');
readln(x);
z:=3+sqr(x)-3*sqr(x)*x;
writeln('z = ',z);
end.
Тестовое решение:
Введите Х 12
z = -5037
// Задание б
var x,d:real;
begin
write('Введите Х ');
readln(x);
d:=x*(sin(x)+cos(x*x)+abs(x));
writeln('d = ',d:0:3);
end.
Тестовое решение:
Введите Х 28
d = 796.395