Составьте программу заполнения массива из ста чисел, со случайными значениями из диапазона от -20 до 20. посчитайте в этом массиве количество положительный и отрицательных чисел.

kisylay85 kisylay85    2   19.07.2019 06:50    5

Ответы
133719 133719  03.10.2020 07:41
Const n=100;
var x : array[1..n] of integer;
   i,k1,k2 : integer;
begin
Randomize; 
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=random(41)-20; 
  write(x[i],' ');     
 end;
 writeln;
for i:=1 to n do
 begin
 if x[i]<0 then k1:=k1+1;
 if x[i]>0 then k2:=k2+1;
 end;
writeln('k1=',k1,'  k2=',k2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика